HostGator » Portal de Suporte

 

Categoria:

Habilitando o PHP 5.3 em seu site


Todos os nossos servidores suportam (isto é, são capazes de executar) tanto o PHP 5.2 quanto o PHP 5.3. A versão default é a 5.2.x, mas você pode seguir os passos abaixo para habilitar a versão 5.3.x do PHP.

Antes de fazer a mudança, tenha em mente que é possível que ocorram problemas de compatibilidade, pois códigos PHP mais antigos podem não ser compatíveis com novas versões do PHP.

Tenha isto em mente: habilitar o PHP 5.3 quebrará quaisquer sites que necessitem do Zend ou ioncube que tenham sido codificados com o PHP 5.2. Recomendamos que você verifique junto ao desenvolvedor da aplicação se existe uma versão para o PHP 5.3 disponível.

Como habilitar

Siga as instruções abaixo, de acordo com o tipo de plano que possuir.

Hospedagem comum (P, M, G, Plus) ou revenda

Atualmente, temos o PHP 5.3.10 (ou superior) instalado em todos os nossos servidores. Um handler (controle) para o PHP 5.3 permite que essa versão do PHP seja utilizada nas contas de hospedagem comum ou revenda. Para fazer uso desse handler, adicione o seguinte código ao seu arquivo .htaccess:

# Habilitar o PHP 5.3
AddType application/x-httpd-php53 .php

Você pode editar o seu arquivo .htaccess via FTP ou através do Gerenciador de Arquivos do cPanel. Para mais informações sobre como fazer isso, consulte nosso artigo: Como editar o arquivo .htaccess.

Servidores dedicados Linux

Não utilize o handler mencionado acima. Em vez disso, envie um email para suporte@hostgator.com.br a partir do seu email de cadastro, solicitando que o Apache seja recompilado para usar o PHP 5.3.

Servidores dedicados Windows

Não utilize o handler mencionado acima. Em vez disso, envie um email para suporte@hostgator.com.br a partir do seu email de cadastro, solicitando que o PHP 5.3 seja instalado.

VPS com cPanel

Não utilize o handler mencionado acima. Em vez disso, envie um email para suporte@hostgator.com.br a partir do seu email de cadastro, solicitando que o PHP 5.3 seja instalado.

VPS sem cPanel

Contas VPS sem cPanel (que só possuem o Virtuozzo Power Panel) não vêm com qualquer versão do PHP instalada. Você pode instalar a versão do PHP que desejar. Observação: contas VPS sem cPanel (que só possuem o Virtuozzo Power Panel) são consideradas sem gerenciamento, de modo que você mesmo precisará compilar e instalar o o PHP.


Atenção

Se você está utilizando um arquivo php.ini customizado que faz referência a módulos que não estão disponíveis no PHP 5.3, seu site pode não funcionar. Remova esse arquivo php.ini customizado (o que fará o servidor recorrer ao php.ini default do PHP 5.3), ou crie um arquivo php.ini que seja compatível com o PHP 5.3.

Artigos Relacionados


Última atualização: 2012-06-25 16:25
Autor: : Pedro Ribeiro
Revisão: 1.4

Categorias

Links Importantes

Envolva-se